' Что делать с ошибкой Strict Standards: Non-static method JLoader? | Шнайдер блог

Что делать с ошибкой Strict Standards: Non-static method JLoader?

Порой новоявленных вебмастеров озадачивает внезапно появившиеся ошибки Strict Standards: Non-static method JLoader. Обычно данная ошибка выскакивает на сайтах Joomla ранних версий, при переносе на новый хостинг или при обновлении конфигурации текущего хостинга. Также ей подвержены и другие старые сайты и движки. Обычно мы рекомендуем обновлять все сборки до самых последних версий, чтобы актуализировать PHP-код, но порой таких возможностей нет и приходится искать иные варианты, чтобы избавиться от этой ошибки.

Причина данной ошибки заключается в том, что версия PHP на сервере слишком высокая, а именно PHP 5.4.x и выше.
Для устранения данной ошибки необходимо переключить версию PHP на 5.2.x или 5.3.x, если хостер имеет такую возможность, либо писать в поддержку хостинга с просьбой включить данную версию PHP.

У нас на хостинге вы легко можете изменить версию PHP при помощи инструмента "Выбор версии PHP" в CPANEL.

Зайдите туда, выберите версию 5.3, нажмите - set current и ошибки на сайте исчезнут. Если это не поможет, попробуйте проделать аналогичное действие, но поставить PHP версии 5.2.

С уважением, Шнайдер-хост.